Back to overview
Degraded

NPPES Service Degradation

Dec 09, 2025 at 04:21pm UTC
Affected services
NPPES Status

Resolved
Dec 09, 2025 at 08:21pm UTC

We’re pleased to inform you that the issue with NPPES has now been resolved.

Our teams have completed the necessary checks and confirmed that services are functioning as expected. Any impacted processes have been re-run where applicable, and normal operations have resumed.

What This Means for You:

The impacted functionality is now fully available.

No further action is required from your end.

We will continue to monitor the system to ensure stability.

We apologize for the inconvenience this may have caused and sincerely appreciate your patience and understanding while we worked toward a resolution.

Please feel free to reach out if you notice anything unexpected or need further assistance.

Updated
Dec 09, 2025 at 05:23pm UTC

We wanted to provide with an update regarding the ongoing issue impacting provider file processing.

At this time, the issue remains unresolved. Our teams continue to actively investigate the disruption, which is being caused by a possible outage or degraded availability in the NPPES service, a dependency within the processing pipeline. As a result, some provider files may continue to fail or experience delays.

Please be assured that this issue has our full attention. Our engineering and operations teams are closely monitoring the situation and are working diligently to restore normal processing as quickly as possible.

What You Can Expect:

No action is required from your end at this time.

Once service stability is confirmed, any impacted files will be reprocessed as needed.

We will continue to provide regular updates and notify you as soon as there is progress or resolution.

We sincerely appreciate your patience and understanding and will keep you informed as we move toward resolution.

Created
Dec 09, 2025 at 04:21pm UTC

We are currently observing provider file processing failures due to a possible service outage affecting NPPES. Our systems rely on NPPES as part of the processing pipeline, and the disruption is resulting in failed or delayed processing of provider files.

Current Impact:
Provider file processing may fail or experience delays.
Pipelines dependent on NPPES lookups may not complete successfully.
No action is required from customers at this time.

Next Steps:
We are actively monitoring the situation and continuing to investigate the issue in coordination with available NPPES status updates.
Once NPPES service stability is restored, affected pipelines will be reprocessed as needed.

We will provide updates as more information becomes available.
We appreciate your patience and will share further updates as we learn more.